Known Issue: CQC Rules Referencing Party Fields Causing Issues with Questionnaires

Product and Version Impacted

  • Matter + Intakes > Case Qualification Criteria (CQC) / Questionnaires
  • Version 24

Issue Summary

We have confirmed an issue preventing Questionnaires from loading on Matters in specific circumstances. When attempting to load a Questionnaire within a Matter, you will receive an error message and the Questionnaire will not load.

CQC error example

Cause

This issue is caused by Case Qualification Criteria (CQC) rules with criteria referencing a field in a Party. We are investigating what about this relationship is causing the error to appear when trying to load a Questionnaire.

Workaround

Since the CQC rules are what’s causing the issue, our current workaround is to bypass the problematic rule(s) and point to a field on an Intake that is pulling the same information as the Party. Below is a workaround that walks you through the process of identifying the problematic field and creating a new rule to bypass it.

This workaround might not work for everyone. If you have walked through the steps below and are still having trouble please don’t hesitate to contact Litify Support at support@litify.com (or Submit a Request). 

Identifying the Problematic Rule

  1. From the Matters page, navigate to the Questionnaire tab.Navigating to Questionnaire section
  2. As soon as you click on the Questionnaire tab an error message should appear.Generate CQC Error
  3. Looking at the error message that appears, you can tell which field on a Party is being referenced in a CQC (and thus causing the error) by looking at the information just before “is not a valid field....”.  Identifying the bad field
  4. Navigate to that rule in the Case Qualify Criteria menu.You can launch this using the App Launcher at the top-left of the page. Navigating to the Case Quality Criteria menu
  5. Find the CQC rule that is using the field from the error message (For example, litify_pm__lit_is_deceased__c) as a Criteria.
  6. Record the information in the Question/Field section.Recording question and field information

Creating a New Field

  1. Click the Setup-Gear at the top-right of the page, and click Setup in the menu that appears.Navigating to the setup menu
  2. Use the search field to locate and launch the Object Manager. Launch Object Manager
  3. Use the search field to locate and launch the Intakes Object Manager.Opening the intake object maanger
  4. Go to Field & Relationships and click New to start creating a new field. Opening field and relationship and clicking new
  5. Click the radio button next to Formula and click Next.Selecting the formula radio button
  6. Enter the Field Label in the box provided. The Field Name should populate automatically based on what you enter in the Field Label box.  Next, select the radio button next to the appropriate Formula Return Type, and then click Next. For the Field Label you’ll use the information you recorded earlier from the Case Qualify Criteria menu.Enter field label and return type
  7. Clicked Advanced Formula and then Insert Field.Inserting a new field
  8. In the box that appears, select the appropriate options depending on the information from the broken rule—then click Insert. Afterwards, you can close this window.Entering new field parameters
  9. Head back to the broken rule within the Case Qualify Criteria menu. In the dropdown under Question/Field you should see your newly created rule. Select your new rule from the dropdown and click Save.Selecting the new rule
  10. You should see a green banner appear at the top of the page that says “CQC Saved Successfully”.
  11. Reopen your Questionnaire again to confirm that the issue is fixed.

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